How to Install Scorch

Please select the browser you use underneath your operating system.

Windows XP, Vista, Windows 7 & Windows 8

Mac OS X 10.6 & Up


Scorch Installation for Windows: Internet Explorer (ActiveX Only)

Please go to www.Sibelius.com/Scorch first to download the latest version of Scorch, version 6.2.0 build 88.

  1. Click Download, and then choose Windows as your platform, enter your email address, and click Next.
  2. When the Scorch website asks you if you want to install the Sibelius Scorch plug-in from Sibelius Software Limited, click Install.
  3. Please wait while the plug-in downloads; it will take a few minutes depending on your connection speed.
  4. If you receive a security warning window, click Install.
  5. Follow the on-screen instructions to complete the installation. Then refresh your browser, and you will now see the trombone example found on the Scorch website.

NOTE: You may need to grant permission to allow Scorch to run on your computer.

Please familiarize yourself with Scorch's many features here. If you are already familiar with these controls, please print a test copy of music by clicking the printer icon found on the Scorch toolbar while previewing a piece.

Back To Top


Scorch Installation for Windows: Internet Explorer, Firefox, Chrome

Please go to www.Sibelius.com/Scorch first to download the latest version of Scorch, Version 6.2.0 build 88.

  1. Click Download, and then choose Windows as your platform, enter your email address, and click Next.
  2. Click on Click here to download Scorch for Windows (English).
  3. Save Scorch620NSPluginInstaller.exe to your computer.
  4. Locate the Scorch620NSPluginInstaller.exe file in your browser's "Downloads"  folder location, and double-click on the .exe file to begin installing the plug-in.
    • To find your browser's Downloads folder, go to:
      • Internet Explorer: Tools → View Downloads (Ctrl+J)
      • Firefox: Tools → Downloads (Ctrl+J)
      • Google Chrome: menu tab → Downloads (Ctrl+J)
  5. Click Run, and then follow the on-screen instructions to complete the installation.
  6. Refresh your browser in order to enable the Scorch plug-in.
    • Firefox Users: You may need to completely restart Firefox to activate Scorch
    • Chrome Users: You may need to completely restart your computer to activate Scorch

NOTE: You may need to grant permission to allow Scorch to run on your computer.

Please familiarize yourself with Scorch's many features here. If you are already familiar with these controls, we recommend printing a test copy of music by clicking the printer icon found on the Scorch toolbar while previewing a piece.

Back To Top


Scorch Installation for MAC OS X 10.6 and Later: Safari, Firefox, Google Chrome

Please go to www.Sibelius.com/Scorch first to download the latest version of Scorch, Version 6.2.0 build 89.

  1. Click Download, and then choose Mac as your platform, enter your email address, and click Next.
  2. To download Scorch, click on Click here to download Scorch plug-in for Mac (English version).
  3. Firefox Users: You will be prompted to open SibeliusScorch620b89.dmg. Click on Save File to save this to your computer.
  4. The Scorch plug-in installation package is now located on your computer in your "Downloads" folder. Double-click on the .dmg icon to open up this folder.
    • To find your browser's Downloads folder, go to:
      • Safari: View → Show Downloads (Command+Option+L or ⌘⌥L)
      • Firefox: Tools → Downloads (Command+J or ⌘J)
      • Google Chrome: Windows → Downloads (Command+J or ⌘J)
  5. Double-click on SibeliusScorch620b89.pkg to begin installing the plug-in.
  6. Follow the on-screen instructions to complete the installation.
  7. Refresh your browser in order to enable the Scorch plug-in.
    • Firefox users: You may need to completely restart Firefox to activate Scorch

NOTE: You may need to grant permission to allow Scorch to run on your computer.

Please familiarize yourself with Scorch's many features here. If you are already familiar with these controls, please print a test copy of music by clicking the printer icon found on the Scorch toolbar while previewing a piece.

Back To Top

How to activate Scorch plug-in in Google Chrome

If you cannot see sheet music rendered by Scorch plug-in in Google Chrome and can only see the "jigsaw" icon in its place, you will have to tell Chrome to allow Scorch plug-in to run. After that, your sheet music will be displayed. Here's what you need to do:

  1. Click the icon in the right of the address bar:
     

     
  2. From the menu, select "Always allow plug-ins on sheetmusicdirect.us" and click "Done":
     

     

Scorch plug-in will now run and sheet music will be displayed. In some cases, you may have to re-load the page.

Back To Top


If you have any further questions, please contact us.